DriveThroughRPGs and VPNs

This is an issue I’ve been having for the past months and just recently solved, so I’ll share the story to help anybody having problems with browsing DTRPG.

So, since about June I was unable to connect to DTRPG from my laptop. Every time I tried to connect I got this error:

At first I thought it was my browser’s fault (I also use it to develop and have it configured toward code inspections and such) but using a fresh one didn’t work. I’ve tried changing a lot of things but nothing worked, so I started to browse it from my phone and e-mail my the files to use them from my laptop.

Today, I was having some issues with my VPN and gosh, DTRPG was working again! My VPN is self-hosted in a datacenter which also works with big companies (I’ve started using them after a very good experience with a company customer which used it) so they probably blacklisted the datacenter’s IP range and blocked all connections coming from them.

So, if you are having trouble with DTRPG, try disabling your VPN (or not browsing it from your company network, which might be blacklisted as well).

1 Like